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1. Introduction RLink for EM6869

1. Introduction
This document describes using an RLink for an EM6869 with Ride7 and the monitor. If you are not 
using this type of hardware, this document is not relevant to you.
This document assumes that you have already read and understood C816 Getting Started for Ride7, 
that you know how to create and use projects for making applications, and how to use the Ride7 
debugger. It does not repeat information from these documents. You can find the C816 Getting Started 
document by clicking in Ride7: > Help > View documentation under C816\Ride7 for C816.

1.1 Purpose of this manual

This guide can be used by anyone interested in programming and debugging EM6869 targets using 
Ride7 for C816.

1.2 Scope of this manual

This document describes how to get started using Ride7 for C816 to compile and debug your 
application or one of the included sample applications. It assumes that you have the prerequisite 
knowledge of the C and C816 assembly languages.

1.1 Additional help or information

If you want additional help or information, if you find any errors or omissions, or if you have suggestions 
for improving this manual, go to the KEOLABS' site for Raisonance microcontroller development tools 
www.raisonance.com, or contact the microcontroller support team.

Microcontroller website: www.raisonance.com
Support extranet site: support-raisonance.com (software updates, registration, bugs database, etc.)
Support Forum: forum.raisonance.com/index.php
Support Email: support@raisonance.com

For information and support about EM68xx chips, contact EM Microelectronic: 
http://www.emmicroelectronic.com

1.2 Raisonance brand microcontroller application development tools

January 1, 2012, Raisonance became the brand under which the company KEOLABS sells its 
microcontroller hardware and software application development tools.
All Raisonance branded products regardless of their date of purchase or distribution are licensed to 
users, supported and maintained by KEOLABS in accordance with the companies' standard licensing 
maintenance and support agreements for its microcontroller application development tools. For 
information about these standard agreements, go to:
Support and Maintenance Agreement: http://www.raisonance.com/warranty.html
End User License Agreement: http://www.raisonance.com/software-license.html
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2. Presentation of the tools
Raisonance provides the following tools for working with EM6869 devices:

● Ride7 + RKit-C816: PC software that builds, programs and debugs EM6869 applications.

● RLink: USB device allowing a PC to communicate with an EM6869 device using the DoCSPI 
protocol, in order to program and debug it.

● EM6869 monitor: software to include in your application for it to communicate with an RLink 
using the DoCSPI protocol, in order to debug your application from your PC while it is 
executing in the physical device.

Each tool mentioned above has a dedicated user manual that you can refer to for more details. 
Documentation for Ride7, SIMICE C816 simulator and RLink-C816 is available on-line from the user 
interface. Before using any of these tools, you must install and register both Ride7 and RKit-C816. 
Make sure you are using the latest versions available for download from the Raisonance Extranet.

2.1 Ride7

Ride7 is the PC software, designed by Raisonance, that you can use to make applications for the 
EM6869, and also to program and debug them using RLink. Please read the Getting Started C816 
document, GettingStartedC816_Ride7.pdf, before continuing. Among other things it explains how to 
register the software, which is free of charge (for the Lite version) but required to use the tools.

2.2 RLink 

The RLink hardware dongle, allows to program and debug the target EM6869 chip from the PC. 
Technically, it is a bridge between a PC USB and many serial protocols. The DoCSPI protocol used 
with the EM6869 devices is one of the supported protocols (in certain RLinks). 
You must install Ride7, which installs the RLink USB driver, before you connect the RLink to your PC.
The RLink features the standard DoCSPI connector as defined by EM Microelectronic. This DoCSPI 
connector connects to an adaptor which allows communication with the EM6819 when it is powered in 
the range 1V to 3.3V. Therefore EM6869 operation is limited to supply voltage range from 1.8V to 3.3V 
in Debug-on-Chip mode. RLink can be used with commercial demonstration boards like the EM6869 
Starter-Kit from EM Microelectronic, and also on any custom board featuring an EM6869 chip and a 
DoCSPI connector. 
There are two RLinks that use theDoCSPI protocol, RLink-GASP-PRO and RLink-GASP-Standard: 
The selection of GASP or DoCSPI is done by using the correct adapter.

• RLink-GASP-PRO programs and 
debugs without any limitation.

• RLink-GASP-Standard has unlimited 
programming capability, but debugging 
is limited to applications no larger than 
2K instructions. It should be used for 
evaluation or for programming in 
production. 

• Other RLinks cannot use the DoCSPI 
protocol. 
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To use the RLink with any EM6869 board, you must plug the female DoCSPI connector of the RLink 
onto the male DoCSPI connector of the target board as shown below.

2.3 EM6869 monitor

The monitor is a piece of software that you can include in your project. It communicates with the RLink 
using the DoCSPI protocol. This allows you to debug your application from your PC while it is running in 
the chip, using the same graphical interface as with the simulator.
The monitor provides you with:

• Unlimited static code breakpoints allowing you to stop the execution at compile-time-defined 
code locations.

• 3 dynamic code breakpoints allowing you to stop the execution at code locations defined (and 
changeable) during debug. These breakpoints can be required by the debugger for performing 
source-level stepping.

• Step-by-step capability allowing you to see the execution of your application line by line (of C) or 
instruction by instruction (assembler).

• Stop while running, so you can see what is happening at any moment.
• Ability to read and write registers and memory locations.

To include (or exclude) the monitor in your application, you must check (or uncheck) the Monitor 
Library linker option: Click Options > Project Properties > LD Linker > Librairies and set option 
Monitor Library to Yes.

Note: If you do not check this option, you cannot debug.

When you have finished designing your application, or if it gets too big, you might want to remove the 
monitor code from it. To do this:

Click Options > Project Properties > LD Linker > Librairies and set option Monitor Library to No. 
This tells the linker not to include the monitor code in the application. Of course, after you do this, you 

- 6 -



RLink for EM6869 2. Presentation of the tools

will not be able to debug it anymore, you can only program it and execute it. As with any linker option 
change, you must link the application again for the change to be taken into account.

Note: When you are NOT debugging, the application runs the same way whether or not you 
included the monitor code in it when you built it. Including the monitor code in the application does 
not mean you must use Ride7 for executing it. The only reason to remove the monitor code is to 
gain code space, or if you want to have full control of every byte of code in your application.
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3. Debugging an example project
This chapter shows you the features of the monitor and their use through a quick tutorial. We will 
debug one of the examples for hardware provided with Ride7.

3.1 Opening the example project

First, open Ride7 using the Windows: Start > Programs > Raisonance Tools > Ride7 > Ride7.

Open this project, using Project > Open Project in Ride7 and select
C:\Program Files\Raisonance\Ride\Examples\C816\EM6869\Toggle_IRQ\Toggle.prj.

Now the project is opened and is ready to be used.
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3.2 Setting debug options

Before starting debug, make sure that the project options are correctly set.
• Open the debugging options window, in which you can tell Ride7 to use the RLink instead of the 

software simulator for debugging (Options > Project Properties > Advanced C816 Options > 
Debug environment).

• When EM6869-Monitor is selected you then select EM6869-Monitor Configuration and click 
on Click here to open options dialogue box to open the EM6869 debug option box. This 
window allows you to test and configure the debugger, the target EM6869 and their connections. 
It also allows you to erase the Flash. Click Connect to RLink to check the connection between 
the PC and the RLink.
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• If successful, this also displays the RLink Serial Number, which Raisonance will need for any 
support request (except of course, if reading the Serial Number fails…).

Note: This Serial Number is NOT written on the RLink. The only way to find it is with this test.

• Click Connect to EM6869 to check the connection between the RLink and the EM6869, and the 
EM6869 power. If successful, this also displays some information about the target EM6869, like 
for example the CRC of the program currently loaded in the Flash. See the EM6869 
documentation from EM Microelectronics for more information on these figures.

Note: If you get any errors while doing this, then you must understand and solve them before going 
on, because the next steps cannot work if these checks fail. The error messages are usually clear 
enough for you to understand and solve any problem. If not, please contact our support team.
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3.3 Starting the debug session

Select Debug > Start, your application will be loaded, run and stopped on main() function.

The Ride7 environment should look similar to the one shown below:

Note: From a user interface point of view, basic debugging functions are identical (stopping and 
resuming CPU execution, setting a breakpoint, single-stepping, checking memory and registers, 
etc.), whether you are using the simulator or a hardware debug tool. Refer to the Getting Started with 
Ride7 to get familiar with the simulator before starting to work with the hardware debuggers.
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3.4 Programming without debugging

During application development it is sometimes preferable, instead of debugging, to simply program 
the Flash and let the application run. To do this, terminate the debug session. Go back to the advanced 
debug options and uncheck the Debug after programming checkbox.

3.5 Using EM6869_pgm.exe

Once your application is designed, debugged and validated, you will probably want to mass produce it. 
This means you will need to program a lot of EM6869 devices with the same code very quickly. If the 
operator is a subcontractor from another company, you might not want him to have your source code. 
For these situations, we provide an executable called EM6869_pgm.exe that allows you to directly 
program hex files (generated by Ride7 during the link of applications) to the EM6869 devices without 
using Ride7. It can also easily be called by a higher-end production and test programs, or just a batch 
file.

1. Open a command prompt using Windows Start menu and use CD command to go to the 
example project’s folder.

2. Execute EM6869_pgm, to see the most recent Help for using it.

3. Execute EM6869_pgm E Ptoggle.axe.hex S. This erases the EM6869 Flash, programs it 
with the example's code from the hex file and starts its execution.
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3.6 Trying the other examples

Ride7 is installed with at least two other examples that deserve your attention, they can be found in 
C:\Program Files\Raisonance\Ride\C816\EM6869. 

• The “Toggle” example is the simplest possible application for EM6869. You can use it as a 
starting point for your new applications by duplicating it and modifying the copy.

• The “Toggle_Custom” is about the same, but it also shows how to use custom startup and linker 
script files. Use it as a starting point for your applications if you need to modify one of these 
template files.
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4. Debugging your own application
This chapter describes using the monitor with your own application - what you need to do and what you 
must be careful about. We cannot guarantee the debugging will work unless you follow this advice.

4.1 Including the DoCSPI connector on the board

When you design your system’s PCB, you must take care that it includes a DoCSPI connector, and 
that this connector is correctly connected to the EM6869 (3 signals), ground, and power (for a total of 5 
signals).
The lines must be short to avoid disturbances. We cannot guarantee that the RLink and EM6869 will 
be able to communicate using DoCSPI if the lines are longer than 10cm between the DoCSPI ADP and 
the EM6869 CPU.

List of pins:
• 1. VBAT: power from target board to RLink.
• 2. TEST_IN
• 6. DoCSPI DATA (PA7)
• 7. GND
• 8. DoCSPI CLK (PA6)
• 9. GND

4.2 Monitor limitations

The monitor is a level-0 IRQ

• It enables some level-0 interrupts and GIE and needs nested interrupts. It will not work properly 
if the application disables these features.

• If your application uses level-0 ITs but does not enable GIE, it will work in debug but not in 
normal execution.

• Other interrupts of any level will not be triggered while the monitor has stopped the execution.
• If the application (more precisely, its startup file) does not handle nested interrupts, you will not 

be able to stop in ISRs of any level. The standard startup does handle nested interrupts.
• If you do not use the default startup and linker script from Raisonance, we cannot guarantee that 

the monitor will work. However, it will work in most cases if you do not modify the sensitive parts, 
which are identified as such by comments.
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• Pressing the STOP button in Ride7 while the CPU is in HALT instruction will make it exit HALT 
mode, altering the normal execution of the application. Ride7 has no way to detect it and 
resume exec properly in HALT mode.

• You cannot set breakpoints on the level-0 IRQ vector, or on the beginning of the level-0 IRQ 
decoding code in the startup. Ride7 will refuse it. You can set breakpoints in your ISRs of any 
level. See the startup code for more information.

• It will not work if the watchdog is activated. The monitor disables the watchdog whenever it 
enters STOP state and never enables it again. Even then, your application should deactivate the 
watchdog if you plan to debug.

• It cannot stop the execution if the CPU is in Sleep or PowerDown mode.

The monitor needs about 20 bytes of software stack

• Beware of stack overflow. If the SW stack is full, the debugger will break the application data. 
Ride7 has no way to detect it and warn you properly.

• The values shown in the data view just below i3 are not correct, you cannot modify them when 
stopped.

• You cannot modify i3 using the monitor (and you must be careful when modifying the PC).
• If the application modifies i3 to some inconsistent value, the monitor will crash. Especially, when 

stopping in or stepping over the modification of i3, it will often crash between the modification of 
the first byte of i3 and the second. Ride7 has no way to detect it and exit properly.

• It initializes i3 to some consistent value at reset. So if your application uses a custom startup 
that does not initialize i3, it might work in debug but not in normal execution mode (power-up 
without RLink).

The monitor needs about 170 instructions of code

• If your application is larger than (<Flash size> - 170), then you cannot include the monitor in it.
• If you are using CodeCompressor, you must make sure you configure it for not modifying the 

monitor.
• You cannot set breakpoints in the monitor code. Ride7 will refuse it.

The monitor uses the DoC peripherals and their SFRs, it is not allowed to modify the other 
peripherals configuration

• If the application modifies the DoC registers, the monitor will crash. Ride7 has no way to detect 
it and exit properly.

• The values displayed in the data view for these registers are not consistent and cannot be 
modified.

• The other peripherals remain active while in the stop state. PWMs go on toggling I/Os, which is 
good; Timers go on counting time, which could be bad, etc.

The RLink is connected to the EM6869 on the PA6 and PA7 signals

• These two pins cannot be used by the application if you want to debug it. You can make 
applications that use these two pins, but you will only be able to program and launch them, not 
debug them.

• Applications using PowerDown Mode will not execute correctly if the RLink is plugged, because 
the RLink includes some pullup resistors that will make the CPU exit PowerDown Mode as soon 
as it is activated. This implies that applications using PowerDown Mode cannot be debugged.
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5. Conformity

ROHS Compliance (Restriction of Hazardous Substances)

KEOLABS products are certified to comply with the European Union RoHS Directive (2002/95/EC) 
which restricts the use of six hazardous chemicals in its products for the protection of human health 
and the environment. 
The restricted substances are as follows: lead, mercury, cadmium, hexavalent chromium, 
polybrominated biphenyls (PBB), and polybrominated diphenyl ethers (PBDE).

CE Compliance (Conformité Européenne)

KEOLABS products are certified to comply with the European Union CE Directive.

In a domestic environment, the user is responsible for taking protective measures from possible radio 
interference the products may cause.

FCC Compliance (Federal Communications Commission)

KEOLABS products are certified as Class A products in compliance with the American FCC 
requirements. In a domestic environment, the user is responsible for taking protective measures from 
possible radio interference the products may cause.

WEEE Compliance (The Waste Electrical & Electronic Equipment Directive)

KEOLABS disposes of its electrical equipment according to the WEEE Directive (2002/96/EC). 
Upon request, KEOLABS can recycle customer’s redundant products.
For more information on conformity and recycling, please visit the KEOLABS website   
www.keolabs.com

- 16 -

http://www.keolabs.com/
http://www.keolabs.com/
http://www.keolabs.com/


RLink for EM6869 6. Glossary

6. Glossary

Term Description

ARM Advanced RISC Machine 

C816 Coolrisc 816

DoC Debug on Chip

DoCSPI EM Microelectronic serial protocol

RBuilder Application builder that allows users to configure device peripherals and out put the 
required C code automatically for their applications. Code is based on libraries provided 
by the manufacturer.

REva Raisonance evaluation platform – modular evaluation boards with main evaluation board 
(motherboard) and daughter boards featuring different microcontrollers

RFlasher Raisonance Flasher: Programming interface for user-friendly flash programming

Ride7 Raisonance Integrated Development Environment 

RLink Raisonance's versatile in-circuit debugger and programmer for 8-bit and 32-bit 
microcontrollers

SFR Special Function Register
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8. History

Date Description

17 Mar 09 Initial version

30 Sep 10 Layout reformat

7 May 2013 Modified cover page, final page and section 1.3 Additional help or information for KEOLABS
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Disclaimer

Information in this document is subject to change without notice and does not represent a commitment 
on the part of the manufacturer. The software described in this document is provided under license and 
may only be used or copied in accordance with the terms of the agreement. It is illegal to copy the  
software onto any medium, except as specifically allowed in the licence or nondisclosure agreement.

No part of this manual may be reproduced or transmitted in any form or by any means, electronic or 
mechanical,  including photocopying, recording, or information storage and retrieval systems, for any 
purpose other than the purchaser’s personal use, without prior written permission.

Every effort has been made to ensure the accuracy of this manual and to give appropriate credit to 
persons, companies and trademarks referenced herein.

This manual exists both in paper and electronic form (pdf).

Please check the printed version against the .pdf installed on the computer in the installation directory of 
the most recent version of the software, for the most up-to-date version.

The examples of  code used in this document are for illustration purposes only and accuracy is not 
guaranteed. Please check the code before use.

Copyright © KEOLABS 2013 All rights reserved
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